Members | Sign In
All Forums > Help & Technical Support
avatar

UPnP not working?

posted Dec 30, 2011 21:53:34 by j9chan
I'm using version 2.0 of the server software and I noticed that the UPnP function is not working. The Remote Access Status would be stuck on "Waiting for router...".

I'm using another app (StreamToMe) which also supports UPnP and it works flawlessly, so I think this is an issue with this software. Anybody experienced the same thing?

Thank you.
page   1
9 replies
avatar
jebauman said Dec 31, 2011 15:13:06
For me either, I just bought 2.0 and I have UPnP enabled on my Netgear Router.

I have also tried setting up a service to port forward to IP and port listed, and still ImageBank reports "waiting on router".

As a side note (feedback): I believe I have a static IP address, but I still went to dyndns.com to check it out. I went to the link posted and I don't think it is linking to the same place you originally intended. I don't see any options to register a hostname or anything free for that matter.


Please advise!
avatar
jebauman said Jan 04, 2012 22:47:24
Too bad this application is not being actively supported.
avatar
ImageBankDev said Jan 05, 2012 04:45:59
Hi, sorry I've been away for the holidays - believe it or not I am still supporting ImageBank.

I'm sorry that the uPnP functionality isn't up to par for you. Do you happen to have multiple routers on your network? I'm finding that people who have this sort of setup are having trouble, and it's something I need to address.

Thanks, and apologies once again.

avatar
jebauman said Jan 08, 2012 14:41:09
Thanks. I hope you had a good holiday. I'm glad you are still here! I do not have multiple routers. I have an Netgear N600 and I updated it to the latest firmware. It still says waiting for router, so maybe it is just that part which is not working? I have not changed anything, but I tried connecting through the remote server this morning and it seems to work! I have UPnP enabled and port forwarding. I'll try to disable to port forwarding for testing the UnP later today.
avatar
ImageBankDev said Jan 08, 2012 18:57:06
Glad to hear it works - does it still say "waiting for router"?

ImageBank Server uses uPnP to setup port forwarding on your router - I don't know if the Netgear router you are using can disable port forwarding altogether - if that's an option please do enable port forwarding :)

avatar
j9chan said Jan 10, 2012 01:25:44
I have a wireless router behind a DSL modem, but I have disabled NAT (Network Address Translation) on my wireless router so essentially there is only one layer of NAT on my network. Unfortunately UPnP is still not working properly on the ImageBank Server. But I was able to get it to work through manual port forwarding so this is just a minor inconvenience. I do have another piece of software that makes use of UPnP and it works perfectly (StreamToMe), so I know the issue has more to do with the ImageBank server than my physical setup.

I would look forward to a future release of the ImageBank server software where this would be no longer an issue. There are users out there who might not be as handy with manual port forwarding and this would benefit them immensely.

Thank you for the great work and please keep it up. May I suggest AirPlay functionality in a future release? Thank you.
avatar
ImageBankDev said Jan 10, 2012 17:09:42
I agree, manual port forwarding isn't for everyone - I'm still trying to work out the kinks with uPnP - the thing that makes it difficult is that different routers may respond in different ways.

About AirPlay, many have asked for it, but it's not supported for photos, only videos, for developer support anyway. This might change in the future if Apple exposes an API for it.

Thanks for your comments!
avatar
sreney said Aug 10, 2012 02:50:27
Problem getting a Remote Server ID.

Running ImageBank server 2.7 on Win 7 64
Router is Verizon FIOS with uPnP enabled and also a static port forward created
Still unable to get Remote Server feature working
As for my static port forward I have: Protocol=TCP Server Ports Source/destination 42111
Any suggestions?
avatar
ImageBankDev said Aug 14, 2012 19:25:40
When it's having trouble getting the Remote Server ID, then it's usually a firewall issue - please also open up port 80 for ImageBank Server so that it can fetch a remote server ID.
Login below to reply: